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BASIC OF NANOMAKER EDITOR 

GDB file 
NanoMaker editor is designed for creating and editing multi-layer hierarchical 
lithographic structures. Designed lithographic structures are saved in data files 
with the *.GDB extension. GDB file format has been specifically designed for the 
efficient storage and quick access to essential information on the lithographic 
structures. The data in the GDB file is stored in binary form. In what follows 
narrative the terms "GDB file" and "lithographic structure" will be synonymous. 

The main structural unit of lithographic structure and GDB file, respectively, is 
named Structure. Each GDB file includes one or may be more structures. Each 
structure in turn comprises a set of geometric objects - elements located in the 
plane. 

Resolution 

Each GDB file is characterized by a parameter Resolution. Resolution is the 
smallest editor cursor step which can be used when creating elements. 
Furthermore, value of Resolution determines the maximal spatial limits of a 
structure. Resolution should be defined at the time of GDB file creation. By 
default, a new file is created with Resolution of 1 nm. In that file a structure 
dimensions are limited from -1000 mm to 1000 mm in each direction. When 
choosing a Resolution follow by the rule that the value of Resolution should be at 
least an order of magnitude better than the minimal size of projected elements 
that will ensure sufficient accuracy of their design. Resolution can not be changed 
after creating of a GDB file. If, however, at designing, the Resolution of a 
structure needs to be changed, create a new file with a required Resolution and 
copy the already created elements to it. 

Structure 

Each structure must have a name. Name of a structure must be unique within 
GDB file. The name is limited to 255 characters. Name of a structure may be 
formed in the Latin alphabet, numbers and some other characters. Structure 
names are case-sensitive. I.e. in one file can be two different structures, one of 
which may be named, for example, a1, and the other A1. 

At the creation of a GBD file, by default, is created a structure named MAIN. This 
structure can not be removed from a file nor renamed. As required, additional 
structures can be added in the file. Their maximum number in a file can not 
exceed 32767 (215-1). 

Elements 

Currently, there are eight types of elements in the GDB file format. Three of them 
are basic - Point, Line and Contour (Polygon). More specific are Time&Date, 
Comments, Structure reference, Dose map and Reference map, which are turned 
into a set of basic elements directly before exposure. Furthermore, for the 
convenience at design stage, there are several derivatives of Contour elements 
which are converted to the contours immediately after completion of input. These 
include: Rectangle, Ring, Circle and Text. 

Basic elements are defined by an appropriate set of coordinates and are 
characterized by the following attributes: exposure dose (Dose), 3D attribute (3D 
Attribute), layer (Layer). Where, 
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Exposure dose - relative value in percentage of resist sensitivity (T/T0), 
showing how many times the exposure of one point of a given element differs 
from the exposure time of a one point of the element with 100% dose. The 
value of this attribute can vary from 0% - 3200% with an accuracy of 0.1%. 
For more information about the resists sensitivity see the product Help. 

3D attribute - relevant only for 3D structures, when you need to create 
three-dimensional structure with the specified profile. It may have different 
meanings depending on the task (e.g. thickness or phase shift). However, it 
can be reduced to the resist thickness by linear transformation. Value of this 
attribute can range from -3200% - 3200% with an accuracy of 0.1%. 

Layer - the value determines whether of this element belongs to one of 256 
layers of a structure. The value of this attribute may vary in the range of 0 - 
255. 

The specific elements have some additional attributes, which will be listed below 
in the description of these elements. 

Layers 

Each structure can contain 256 layers (from 0th to 255th) and allows one to 
distribute elements by these layers for technological needs, such as multilayer 
lithography with layer by layer alignment, for example. 

3D attribute 

To create a three-dimensional (3D) structure the 3D characteristic must be 
defined when you create a new GDB file. 

Cutting Grid (Database Cells) 

To optimize the solutions of some tasks associated with data preparation or 
directly with the exposure, the interior structure can be divided into square cells 
by a grid. Grid spacing can be arbitrary value. Elements, which intersect by a 
grid, cut into separate elements on the boundaries of the grid. In the presence of 
the grid, all operations with elements are executed sequentially when traversing 
the grid cells, one after another. At first, an operation is performed with the 
elements within a current cell and only then with the elements of the next cell. 
I.e. a grid organizes sequence of operations with elements of a structure. In order 
to make an exposure with stage displacements, cutting a structure by grid is 
mandatory. In that case, grid organizes subfields (their size is determined by the 
grid), between which movements are made. Cutting grid drawn in orange. 

Editor Window and Menu Commands 

When you open an existing or create a new GBD file at least one window is 
opened – a view, which shows structure MAIN. Each structure contained in GDB 
file can be opened in a separate window for viewing and editing. 

To create a new GDB file, click the New Database... in the menu File (File-
>New Database...). In the New Database File dialog leave all fields 
unchanged and click OK. 

There is only one structure in a new file, which is named as MAIN and initially 
empty, i.e. does not include any elements. 

The title of the editor window displays file name, structure name, attribute of 
spatial dimension (2D or 3D) and the window serial number, separated by a 
colon, as for example in Fig. 1. 
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Fig. 1  Editor windows for just created MAIN and Second structures 

With the default settings, an editor window displays the scale bar in red in the 
upper left corner, and window space is lined by coordinate grid that is drawn in 
green. This is the design grid. Two mutually perpendicular thickened lines 
traverse through the centre of the coordinate system marking the coordinate 
axes. Grid spacing is always equal to size of the scale bar. 

The cursor is always attached to the mouse pointer and its current coordinates 
are displayed in two editable fields lying on status bar at the bottom frame of the 
program. These coordinates are shown in microns invariably. To the right of 
them, in the next field, the cursor step is displayed in the appropriate units. In 
the utmost right field is shown a number of selected elements (see Fig.1). 

Toolbar 

The toolbar at the left frame of the main window gives quick access to basic 
functionality of the program (see Fig.1). Its buttons are arranged in two vertical 
rows - the left line provides access to main functions and dialogs and the right to 
the editor commands. 

Scale 

When you open an editor window the scale is chosen such that the whole 
structure is visible. Later on, if you change the scale of displayed structure, the 
scale bar will be resized and, accordingly, grid spacing will be changed. 

For quick zooming, use mouse wheel or press / and * on the numeric keypad. 
Note that increase or decrease of displayed fields realized relative to the current 
cursor position. Thus, for convenience of editing, different areas of a structure 
design can be moved to centre of the window while increasing or decreasing the 
display scale. 

In order to move the displayed fragment of a structure without changing the 
scale, click and hold the left mouse button, drag the cursor to desired position in 
the window and release button. 

In order to see the structure entirely, press the = key. 

Cursor Step 

Cursor step - is the distance at which the cursor moves in the editor window after 
pressing any arrow key on keyboard. Cursor step can be set over a wide range, 
which also depends on the file Resolution. When you create a new file with the 
default Resolution of 1 nm, the Cursor step is 1 μm, which is quite convenient. 

To quickly change the Cursor step use the + and - keys on the numeric keypad. 
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In order to accurately move the cursor to the nearest node of the design grid, for 
example, when creating a new element, press Shift key. 

Display Mode 

NanoMaker Editor can display elements in a few modes. 

Contour displaying mode 

By default, when you open new editor window the Contour (Layers) mode is 
always set. In this mode, elements in visible layers are displayed as coloured 
outlines. Outline colour depends on the layer number. Correspondence is 
given via a palette dialog box (shown in Fig. 2). Totally possible to set 16 
different colours that will encode the first 16 layers and will periodically 
repeated in all subsequent layers. 

 
Fig. 2 Defining of the layer's coding palette in Layers Coding Palette dialog 

To set Contour displaying mode select View->Redraw->Contour menu 

command or press Alt+C shortcut keys or press  button on the toolbar. 

Dose displaying mode 

In Dose mode all elements in visible layers are displayed as coloured shaded 
areas. Each shading colour encodes a certain dose range. When this mode 
enabled, the additional panel with colour scale divided into 16 such intervals 
is opened.  

The range of displayed doses is given in Min Level [%] and Max Level [%] 
fields of Editor tab in View Options dialog (to open the View Options 
dialog choose Options->View... menu command). Compliance of a dose 
range with a colour is defined via the Dose Coding Palette dialog. To open 
this dialog click Dose Palette... button in Editor tab. The Dose Coding 
Palette dialog is similar to that shown in Fig. 2 for color coding of layers. It is 
possible to set 16 different colors, which will encode 16 dose intervals within 
a chosen range. If dose of an element lies outside the lower or upper limits of 
the defined range, the element will be displayed in the colors of the 
lowermost or uppermost interval, respectively. 
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The Contrast Palette is set by default to code dose intervals in chosen dose 
range, but you can override it on your own. 

To set Dose displaying mode select menu command View->Redraw->Dose 

or press Alt+D shortcut keys or press  button on the toolbar. 

3D Attribute displaying mode 

In 3D Attribute mode all elements in visible layers are displayed as coloured 
shaded areas. Each shading colour encodes certain 3D attribute range. When 
this mode enabled, the additional panel with colour scale divided into 16 such 
intervals is opened. Compliance of a 3D attribute range with a colour is 
defined via the 3D Attribute Coding Palette dialog, where you can set a 
correspondence between given 3D attribute ranges and different colours. 

To set 3D Attribute displaying mode select menu command View->Redraw-
>3D Attribute or press Alt+3 shortcut keys. 

Displaying of layers (active layers) 

There are other options of showing elements in the editor window, for 
example, show or hide elements lying in some layers. By default, each 
structure is set in mode to show all elements in all available layers. To hide 
any of the available layers, choose the menu command View->Redraw-
>Layers... or press the Alt+Y shortcut keys. Then, in the opened Active 
Layers dialog find the layers in list, deselected them and then click OK 
button to close dialog. Conversely, to make some layers visible, it is 
necessary to select them in the list. 

Important! Most of the editorial operations (delete, transform, grouping, 
ungrouping, etc.), as well as exposure are performed only for elements in 
visible (active) layers, even if these elements were selected before they 
appeared in no displayable layers. 

Hierarchy levels 

When a hierarchical structure is displayed in the editor window, the top (0th) 
level of the hierarchy is demonstrated by default. Press the 1, 2, 3 or 4 keys to 
show the following levels of hierarchy - first, second, third, or to the lowest level, 
respectively. Switching the levels of hierarchy can also be performed via View-
>Hierarchy menu command. 

Structure design 

Creating of a new structure 

As mentioned above, when opening a new file, it contains only one structure, 
which is named MAIN. To add new structures to the file - open Edit Structure 
dialog (Edit->Structure...) and then click the New button. In the opened New 
Structure dialog, enter a name of a new structure, which must be unique within 
the file (see Fig. 3). Click OK to close the New Structure dialog and to create 
the structure. The structure's name you will find in list in the Edit Structure 
dialog. Similarly you can add any number of new structures. To open the newly 
created structure in editor window, select it in the list and click Edit button. 

A new structure can be created on base of the design of the existing structure. 
For example, if you want to moved or copy some of the elements to a separate 
structure, select them and choose the Edit->Group... command from the menu. 
As a result, the Group to Structure dialog will be opened. Specify a name for 
the new structure and check Delete Elements checkbox, if you want to move 
selected elements in the new structure. Check In New Editor Window 
checkbox, if you want to show the newly created structure in editor window after 
closing the dialog 
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Fig. 3 Creation of a new structure in New Structure dialog 

Deletion of a structure 

To delete an existing structure, open Edit Structure dialog (Edit-
>Structure...), select the structure in list, and then click Delete button. As a 
result of this operation, the structure and all its elements will be permanently 
deleted. This doesn't work if there are references to this structure in the file. In 
that case you should remove the references from the other structures first and 
only then try to delete the structure. 

Changing of attributes of existing structure 

To rename an existing structure, open Edit Structure dialog (by Edit-
>Structure... menu command), select the structure from list, and then click 
Modify button. In the opened Modify Structure dialog, change the structure's 
name. A new name also must comply with the rule of structure naming that has 
been described above in the Structure section. 

Furthermore, Modify Structure dialog allows you to change size of the cutting 
grid. 

If grid was not set yet, check the Allow Divide by Grid checkbox and set desired 
grid size in the Grid Size [um] field. 

If, conversely, you want to cancel the cutting grid, uncheck the Allow Divide by 
Grid checkbox. 

Further, dialog allows to determine the structure origin shift relatively to center of 
the writing field (Scan Field). The structure origin is the same as the design origin 
(point with 0, 0 coordinates). 
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Often structures are designed unsymmetrical relatively to the center of 
coordinates. So, sometimes, exposed structure can not fit in the Scan Field, even 
though its own dimensions not exceed the dimensions of the Scan Field. This is 
because the structure origin coincides with the center of Scan Field by default. To 
resolve this problem, set an offset of the structure origin in the fields Origin X 
[um] and Origin Y [um]. 

Parameters XY Range [mm] give an information about the maximum possible 
dimensions of the structure at this Resolution of the file. More information about 
the maximum possible dimensions was mentioned above under Resolution 
section. 

Click OK button to close the dialog box and make changes. 

Summary of structure 

To display summary information about the structure choose menu View-
>Summary... or press the Alt+= shortcut keys. The Summary of "<name>" 
Structure dialog displays information about the structure's dimensions, total 
number of elements, number of references to structures and number of selected 
elements. This is followed by information about attributes, such as, Resolution, 
Cutting Grid size and 3D availability. And below follows information about layers 
(see Fig. 4). 

 
Fig. 4  A summary of the structure 

Defining the current values of attributes for a new elements 

So, in order to start designing a new structure or edit an existing design, you 
need to open an editor window containing this structure. How to do this is written 
in the previous section. 

 
Fig. 5  Defining initial values of the attributes in the Attributes dialog 
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Before creating of a new element, open the Attributes dialog (by Insert-
>Attributes... menu command or by pressing A hotkey) to set values of the 
several parameters that will define attributes of new element. 

In the initial settings of the dialog (see Fig. 5): 

Dose is equivalent to 100%; 

Layer is set to 0; 

Width of polylines and points equivalent to 0 μm; 

Height and Width of input text characters is equivalent to 8 μm and 5 μm, 
respectively; 

Number of Segments to approximate π/2 degrees arc when entering rings and 
circles equal to 8. 

Change the settings, if necessary, and close the dialog by pressing OK button. 
Now, each newly created element will have attribute values in accordance with 
the values set in this dialog. If later, after inserting a certain number of elements, 
you will need to change any of the attribute for subsequent input elements, 
reopen the Attributes dialog and change the value. 

Creating new elements 

There are several ways to enter the basic elements using the keyboard and 
mouse. Let's consider an example of a rectangular element input. To introduce 
insert mode, you can use the menu command Insert->Rectangle or simply 

press R hotkey (or click  button in the toolbar). As evidence of transition to 

this mode will be appearance of the corresponded cursor  and capture of the 
mouse pointer within editor window. Then you can use these techniques: 

Graphical input with a mouse 

Move mouse pointer to point of the first vertex of the future element. For 
exact hit in the coordinates you need, turn mouse wheel to zoom in to a 
sufficient accuracy. Click the left mouse button to enter the first vertex. If 
necessary, zoom out and move pointer to position of the next (the opposite in 
the case of a rectangle) vertex. Zoom in again if it is necessary for exact hit in 
the coordinates. Click the left mouse button to complete the insertion of the 
element. As long as the input is not completed, undo of the previous vertex 
can be done by right-clicking. 

Graphical input from the keyboard 

Move mouse pointer close to point of the first vertex and leave the mouse 
alone. Further, using the Arrow keys, move cursor to the coordinates you 
need. At the same time, to accurately hit the desired position, use jointly: 

- the Shift key to set cursor exactly in the closest node of coordinate grid, 
-  the - and + keys for adjusting the cursor step, 
-  the / and * keys to scale view. 
When eventually the cursor is in the correct position, press Space to enter the 
vertex. In case of error, press Backspace to cancel just inserted vertex. Then, 
using the arrow keys (or mouse), move the cursor to the next (opposite) 
vertex. If necessary, use again the - and + keys for changing the cursor step 
and the / and * keys for scaling. When the cursor is end up in the correct 
position, press Space to enter the vertex and finish entering of the rectangular 
element. 

Keyboard input in digital form 

Press X hotkey, to set the keyboard focus in the field, which is used to display 
(and input) current coordinate of the cursor, and is a part of the program 
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status bar (at the bottom of main window). Enter numerically the X-coordinate 
of the first vertex of the element. Press Tab key to move the input focus in the 
field, which displays Y- coordinate and enter into this field in numerical form Y- 
coordinate of the vertex. Press Enter to return focus to the editor window. 
Press Space to enter the vertex of the element. Again press X, to move the 
keyboard focus in the field, which displays position of the cursor and repeat all 
the steps above to enter the next vertex of the element. 

Any of the following methods can be combined in an arbitrary way on the base 
of personal preference. 

For your convenience use Multiple Insert mode at entering a number of similar 
type elements. You can set this mode by choosing Insert->Multiple Mode 
menu command (either by pressing H hotkey or by pressing the lowest button 

 on the toolbar). In this mode, a few elements of the same type, for 
example rectangles, can be entered successively, one by one, by choosing the 
insertion command only once before the first input. To exit the Multiple Insert 
mode press Esc. 

In general, when you enter different types of elements with an arbitrary 
number of vertices, a vertex input is usually done by pressing the Space bar 
or the left mouse button. Completion of an element input is fulfilled by 
pressing the Enter key or double-clicking the left mouse button. Cancel of the 
newly introduced vertex is performed by pressing the Backspace key or right 
mouse button. Quitting the input is accomplished by pressing the Esc key or 
double-clicking the right mouse button. 

Digital input using dialog 

There is also possibility to introduce the basic elements in a digital form using 
input fields in the dialog. To insert, for example, a rectangle, choose the 
Insert->Numerically->Rectangle menu command. In the opened dialog, 
select the first row in the Element's Nodes [μm] window, which contains 
coordinates of one of the vertices of a rectangle (conventionally it is termed as 
<left-bottom> vertex). Make the row editable by pressing Space bar (or click 
the left mouse button or selecting Edit from the context menu that pops up 
after clicking the right mouse button on the row). Enter coordinates of the 
vertex instead of present numbers in a row. Be sure to leave separating space 
between X and Y coordinate. Go to the second row in the window and edit 
coordinates of the opposite vertex. Click Apply button to enter the element 
without exiting the dialog and continue typing coordinates of next rectangle in 
this manner. 

 
Fig. 6  Inserting of an rectangle with the  Insert Rectangle Numerically dialog 
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Similarly may be entered points (Points), polylines (Polyline), rectangles 
(Rectangle), contours (Contour), circumferences (Circle) and rings (Ring). 

When entering a circumference or a ring the coordinates in first row determine 
the position of centre, and subsequent row(s) determine radius(radii) of the 
circle(s). 

Creating of other more complex types of elements will be described later. 

Selection of elements 

Any operation in the editor to transform geometry or attributes of elements, as 
well as deletion and copying runs only for selected elements. Number of selected 
elements in the structure can be seen in the rightmost field of the program status 
bar. 

To select all elements in a structure, press Alt+A shortcut keys or select the 
Edit->Select->All menu command. 

To select only relevant elements, use one of the commands in the menu Edit-
>Select: 

• In - allows to select elements that are entirely within arbitrarily delineated 
rectangular area. Use mouse or keyboard to draw the enclosed area; 

• At - allows to select element which is located under the cursor; 

• Layer... - allows to select elements lying in the chosen layers; 

• Reference... - allows to select elements, which are references to selected 
in list structures. 

To deselect all elements in structure, press the Shift+Alt+A shortcut keys. 

To deselect only relevant elements, use one of the commands in the menu Edit-
>Unselect: 

• In - allows you to deselect elements that are entirely within arbitrarily 
delineated rectangular area; 

• At - allows to deselect element which is located under the cursor; 

• Layer... - allows to deselect elements lying in the chosen layers; 

• Reference... - allows to deselect elements, which are references to 
selected in list structures. 

In addition to the above options, you can use Select/Deselect modes of the 
mouse pointer. To set Select/Deselect cursor mode, choose the Edit->Select 

Mode menu command or press the Alt+M shortcut keys (or press the  button 
in the toolbar). In Select mode: 

• Double-clicking the left mouse button in editor window allows to select all 
elements of a structure; 

• Single click with the left mouse button over the element allows to select 
only this element. 

• Drawn with the pressed left mouse button the dashed rectangular outline 
selects all elements placed inside the rectangle. 

• Clicking the right mouse button turns selection mode, for example, from 
Select to Deselect. In Deselect mode: 

 Double-clicking the left mouse button in editor window allows to 
deselect all elements of a structure. 

 Single click with the left mouse button over the element allows to 
deselect only this element. 

 Drawn with the pressed left mouse button the dashed rectangular 
outline deselects all elements placed inside the rectangle. 
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• Each new right mouse click inverts selection mode. Current selection mode 
easily ascertained by type of the cursor. In Select mode, there is a plus 

sign in the cursor . While a minus sign is present in cursor in Deselect 
mode. 

To exit cursor selection mode, press the Esc key or double-click the right mouse 

button . 

Deletion 

To delete some elements of a structure, first select them and press the Delete 

key (or choose Edit->Clear menu command or click  button in the toolbar) 
then. 

Cutting (moving to the clipboard) 

To delete some elements with the possibility of subsequent pasting them to a 
structure, first selects the elements and press Shift+Delete key combination (or 

choose the Edit->Cut menu command or click  button in the toolbar) then. 

Copying 

To copy (put on the clipboard) one or more elements of a structure, first selects 
them. Then select the Edit->Copy menu command, or press Ctrl+Insert key 

combination (or the  button in the toolbar). 

Pasting 

In order to paste an element (or group of elements) previously placed on the 
clipboard as a result of Copy or Cut operation, select the Edit->Paste menu 

command or press Shift+Insert key combination (or the  button in the 
toolbar). Immediately thereafter, the insert mode is activated: the pointer is 
captured in the window, a special cursor appears, contours of the inserted 
elements are drawn in dashed lines in the window, and Transform Info panel 
opens. The geometric center of the contours is marked by dashed crosshair. 
When mouse cursor is over the image of the elements within an imaginary 
rectangular area that outlines its outstanding vertexes, the cursor takes form of 

the pointer with a crosshair . If the mouse pointer is outside an imaginary 

rectangular area, the cursor takes form of a pointer with open circle , 
symbolizing the rotation operation. 

To move the contours to the right place in structure, place the cursor inside the 
imaginary rectangular area, grab the image by pressing the left mouse button 
and hold it while dragging to the right place. 

If you want to rotate the contours, place the cursor out of an imaginary 
rectangular area, grab the image by pressing the left mouse button and hold it 
while moving the cursor along arc of a big circle, which outlines the image, as 
long as the contours will get the desired position. 

Before dragging, move mouse pointer close to geometric center of the image at a 
distance less than half the cursor step. Now, when you press the left mouse 
button, the pointer will jump to the position of the geometric center. And thus, at 
the further dragging, it is easier to control position of the image. For greater 
convenience and accuracy, use the arrow keys to move the image with cursor 
steps. If necessary, use the - and + keys to change the cursor step, as well as / 
and * keys (or mouse wheel) to scale. 
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To paste the elements in the right place press Enter key or double-click the left 
mouse button. 

To cancel paste, press the Esc key or double-click the right mouse button. 

By the way, it is possible to paste elements not only in structure where they have 
been copied, but in any other in this file and in other lithographic structure as 
well. 

Undo/Redo of last actions 

In order to undo/redo last action on delete/paste elements, use the Edit-
>Undo/Edit->Redo menu commands (or Ctrl+Z / Ctrl+Shift+Z shortcut keys, 
respectively). 

Creation of other elements 

Text 

To add labels to a structure design it is convenient to use the Text element. 

By using the edit field in the Insert Text dialog, which is called by the Insert-
>Text... menu command (or by pressing T hotkey), you can type the text you 
want and format it properly. In the text you can use uppercase and lowercase 
letters, digits and other keyboard symbols. After closing the dialog by pressing 
OK button, insert mode is activated: the mouse pointer is captured in the 

window, the corresponded cursor appears , to which the input text image 
hooked. Move the cursor to desired location in the structure and place the text as 
need. Use the / and * keys (or mouse wheel) to scale the editor window, the 
Shift+/ and Shift+* key combinations to change size of symbols in the text, the 
Shift+R key combination to rotate the image by 15 degrees. 

To enter the element, press Return key or the left mouse button. When entering, 
the Text is transformed into a set of independent contours and does not exist as a 
single element any more. 

Time&Date 

This is the special element that is embedded in the design of structure in order to 
mark the date and time of an exposure process. 

To insert the element, select the Insert->Time&Date menu command (or click 

 button in the toolbar). Further, in insert mode, use the actions and 
commands described above for the Text element, to fit in the Time&Date element 
with the desired dimensions in the requisite location of the structure. 

Unlike the Text element, when you insert the Time&Date element, it is not 
transformed into a set of contours, but exists as a single object with some specific 
properties. For example, overall dimensions of an element are defined 
approximately and depend on the format of date and time presentation, and 
continually fluctuate within a small range in accordance with the current time. 
You need to take this into account when insert this element in the design of a 
structure. Next, when set a dose for Time&Date element, be aware that the 
proximity effect correction procedure does not adjust the dose and do not take 
into account its presence near the corrected elements. 

To change format of date and time presentation, and may be, add some 
comments into string - selects only this Time&Date element and use the Edit-
>Modification... menu command. Detailed description of the presentation 
formats and examples can be found in the program Help. 

Additional attributes of the Time&Date element are format string of date and/or 
time representation, as well as matrix of coordinate transformation. 
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Comments 

This element, as well as the Text, can be used to add labels and comments in 
structure design. To insert element, select the Insert->Comments menu 
command and in the opened dialog, type the comment text. String length is 
limited to 255 characters. Click OK button, in insert mode, use the actions and 
commands described above for the Text element, to place Comments as desired, 
with the right size in the right place of a structure design. 

Unlike the Text element, where the inscription can be formatted into multiple 
lines, text in the Comments exists as a single line. As the Time&Date element, 
Comments is not transformed into a set of contours at insertion and exists as a 
single unit with specific properties. In particular, the comment text can be 
completely overridden by a special command at exposure in batch mode (for 
details, see the Help for Batch mode). Replacing of a text may change size of an 
element. This fact must be taken into account when you insert this element in 
design of a structure. Next, when set a dose for Comments element, like for 
Time&Date, be aware that the proximity effect correction procedure does not 
adjust the dose and do not take into account its presence near the corrected 
elements. 

To change the text of the commentary at the design stage - selects only this 
element and use the Edit->Modification... menu command. 

Additional attributes of the Comments element are commentary line, as well as 
matrix of coordinate transformation. 

Structure reference 

To optimize design of a structure and reduce size of the data file the duplicate 
elements may be transposed into a new separate structure in this file, and then, 
the reference to new structure can be inserted into the original structure into the 
right place. Thus, the original structure becomes hierarchical comprising a link to 
another structure in this file. Similar references to new structure (Structure 
reference elements) can be inserted as many times as need to arbitrary locations 
of the original structure. Each reference to a structure at insertion can be 
repeated many times at given steps in the horizontal and vertical directions (so 
called Array of Structure references), rotated to any angle, and zoomed in or out. 
In turn, each of inserted structures may include references to other structures 
from this GDB file, thus, forming the next level of the hierarchy and etc. 

 
Fig. 7  Insertion of a Structure reference element by using Insert Structure dialog 
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However, recursive looping of references is forbidden, and so, the program is 
watching for this and doesn't allow to perform such insertion. 

In order to insert a Structure reference choose the Insert->Structure... menu 
command and in the opened dialog select a structure to be referenced from the 
Structure Name list. Specify an insertion point as a shift of the structure origin 
in the Inserting Point fields. Set, if necessary, rotation angles in the Rotate 
fields, scale factors in the Magnification fields, number of repetitions and steps 
in the Repeat fields, dose change factor for elements of the structure in the 
Dose Factor field and press OK. 

Structure reference element is drawn by rectangular area bounded by thickened 
blue contour. The boundary of the area passes through the protruding vertexes of 
the elements in the inserted structure. Through the center of the element passes 
the inscription in red, which contains the name of the referenced structure. If 
structure is referenced as array, then number of repetitions in square brackets is 
added in the inscription also as you can see on Fig. 8. 

 
Fig. 8  Array of structure line_50nm_20um references in the MAIN structure 

A file of one of the supported formats GDB, ELM, GDS, and DXF can be inserted 
as Structure reference. To insert other file as Structure reference to the current 
file, choose the Insert->File... menu command and, in the Open dialog, browse 
and select the file you want to load. All structures of the selected file will be 
copied to the current file. The former MAIN structure from the selected file in the 
current file will be named after its former file. If the selected file doesn't contain 
MAIN structure, then an empty structure named after its former file will be added 
to the current file. The new Structure reference element will refer to a structure 
named after the inserted file. 

To display elements of a referenced structure on the first level of the hierarchy, 
press 1 on keyboard. 

The Structure reference element has no such attributes as dose, 3D attribute, 
layer and always is listed in the 0 layer. Its attributes are: insertion point, 
rotation angles, zoom factors, number of repetitions and steps as well as dose 
change factor. 

To change attributes of the Structure reference - selects only this element and 
choose the Edit-> Modification... menu command to open the Modification of 
Structure Reference dialog. 

A special case of Structure reference insert is the insertion of a file, as was 
mentioned above. By inserting a file, you are actually creating a reference to 
structure MAIN of the inserted file (to former structure MAIN, which is copied to 
current file and renamed after its former file name). After inserting the data from 
the file, its further presence is not required. 

Dose map 
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NanoMaker allows to design lithographic structures on the basis of information 
contained in raster images. To perform this task there is the Dose map element. 
Such element is created on base of image parameters and references to basic 
structure. The simplest basic structure may contain a single circle, single square 
or polypoint. At creation of the element a matrix of the basic structure inserts 
(array of Structure references) is formed, where the number of rows and columns 
equal to width and height of the image in pixels, respectively. Thus, each pixel in 
the image corresponds to one of the references to the basic structure. The 
intensity of a pixel, which is calculated as (R+G+B)/3, is used as a multiplication 
factor in determination of resultant dose for elements from inserted basic 
structure. By default, the steps in array of Structure references have chosen 
equal dimensions of the structure, so that the inserts fit tightly to each other as 
the pixels in the original image. If desired, the steps may be changed. 
Furthermore, the matrix can be rotated and scaled. GDB file, containing Dose 
map elements, must be moved together with the images, which are used to 
design these special elements. 

You can create a Dose map element in one of two ways: 

• import an image by command File->Import->(using TIFF Image Files 
(*. TIF) or Bitmap Image Files (*. BMP) templates); 

• use the Insert->Structure with Dose Map... menu command and insert 
into current structure an array of references to some structure from this 
file based on the selected image. 

Fig. 9 shows a dialog that opens when you import the image data from the 
chosen file. In this case the selected file is splnano_15.bmp, which will be the 
basis for a Dose map element. As filling structure the CIRCLE_(D_1μm) is 
selected, which consists of a circle of 1 μm diameter. 

 
Fig. 9  Creation of a Dose map element on base of splnano_15.bmp image file 

 and CIRCLE_(D_1μm) structure. 

To display elements of an inserted structure on the first level of the hierarchy, 
press 1 key. To display doses press the Alt+D shortcut keys. 
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Dose map element has the same attributes as the Structure reference and 
additionally stores file path to linked image. 

The resulting structure after insertion of Dose map element at the first level of 
hierarchy in Dose displaying mode is shown on Fig. 10. 

 
Fig. 10  The resulting structure after insertion of Dose map element 

To change Dose map attributes - selects only this element and use the Edit-
>Modification... menu command. 

Dose map element depicted in substantially the same manner as array of 
Structure references. Additionally, in the centre of Dose map, below the name of 
the referenced structure, also in red, but in a smaller font appended word 
DoseMap and path to the associated image file. 

Reference map 

To design and produce rainbow holograms a special element was developed that 
represents a matrix of references to named structures, which is organized on the 
basis of information stored in an associated image. This element is the Reference 
map. 

Linked image is stored in a separate file of BMP or TIFF format and has a colour 
depth of 8 bits per pixel. Image size (number of pixels per row by the number of 
pixels per column) determines size of the matrix of references (and of the 
hologram itself). The gray level of each image pixel (a number from 0 to 255) is 
the key to substitution of the corresponding structure in each nodes of the matrix. 
This is possible because all referenced structures in Reference map are named 
according to a certain rule. Their names consist of an optional prefix and a 
number. The prefix is the same for all structures and can contain any number of 
characters of the Latin keyboard. The number consists of three digits value from 
000 to 255. For example, if prefix is "Toy-", then names of the referenced 
structures in the file will be as follows: "Toy-000", "Toy-021", "Toy-205"and so 
forth. Thus, each Reference map can refer to 256 different named structures. 

Design of real hologram can contain tens Reference map elements to create 
different colour, dynamic and other effects. 

You can create a Reference map element in one of two ways: 
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• import design of rainbow hologram prepared by "RainBow" software by 
choosing the File->Import->(and then the Elements Files (*.ELM ) or 
GDSII Files (*.GDS;*.CSF) templates) command; 

• use the Insert->Structure with Reference Map... command to insert in 
the structure a matrix of references to structures from a given file. I.e., 
structures to be referenced must already exist in the file at the time of 
Reference map creation. It is also necessary to adhere to naming 
conventions for the structures. If referenced structures do not exist in the 
file, Reference map will be empty. 

To check the result of element creation, open to view the first level of the 
hierarchy by pressing 1 key. 

Reference map element is depicted in much the same way as the array of 
Structure references - blue rectangle limits the space of inserted structures; 
inscription in the centre in red colour consisting of name of the referenced 
structures (a prefix followed by set of symbols <xxx>, symbolizing changing 
number from 000 to 255), and then added in brackets the number of rows and 
columns. Additionally, in the centre of Reference map, below the name of the 
referenced structures, also in red, but in a smaller font appended word RefMap 
and continue the path to the linked image file. 

To display elements of inserted structure on the first level of the hierarchy, press 
'1' key. To display doses press the Alt+D shortcut keys. 

Reference map element has the same attributes as the Structure reference and 
additionally stores file path to linked image and the prefix string. 

To change Reference map attributes - selects only this element and use the Edit-
>Modification... menu command. 

Transformation of elements 

Depending on the editing tasks and on type of element to be edited, there are 
several transformation methods. 

1. Changing of Attributes 

In order to change dose, layer (3D attribute, in the case of 3D structures) of 
elements it is necessary to selected them, and then open the Change 
Attributes dialog by choosing Edit->Change Attributes... menu command 
or pressing hotkey B. 

 
Рис. 11 Changing of element's attributes with the Change Attributes dialog 

Since dialog allows to edit multiple attributes at the same time, pay attention 
that selectors of all operations are initially set in NONE state (see Fig. 11). 
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If you want to change dose - set selector of operations with dose in the state 
SET and enter the new value for dose in the Dose [%] field. 

If you want to increase/decrease dose in any number of times, set selector of 
operations with dose in the SCALE state and enter the new value for factor in 
the Factor field. 

If you want to change layer number - set selector of operations with layers in 
the SET state and enter a new layer in the Layer Number field. 

If you want to change 3D attribute - set selector of operations with 3D 
attribute in the SET state and enter the new value for 3D attribute in the 3D 
attribute field. 

If you want to increase/decrease value of 3D attribute in any number of times, 
set selector of operations with 3D attribute to the SCALE state and enter the 
new value for factor in the Factor field. 

Click OK button to perform the changing of attributes. 

To change additional attributes of not the basic elements (Time&Date, 
Comments, Structure reference, Dose map and Reference map) you 
should selected only one of these elements and then open modification dialog 
by choosing the Edit->Modification... menu item or by pressing 'M' key. A 
set of attributes available for changing and dialog appearance depend on the 
type of selected element: 

• for Comments element only string of information is available for 
correction; 

• for Time&Date elements output format and string of comments may be 
adjusted; 

• For Structure reference, Dose map and Reference map elements the 
parameters of transformation matrix, insertion point, coefficient of dose 
changes, as well as referenced structure (or structures) are available 
for changing. For Dose map and Reference map you can also change 
linked image. 

 

2. Changing of geometry 

Skew 

To change shape of a basic element, first selects only this element, and then 
choose Edit->Transform->Skew menu command (or use the Ctrl+Shift+S 
shortcut keys). 

Small brown rectangles will mark the active areas of control points at the 
vertices of the element, which is subjected to transformation. To change 
position of a vertex, grab its control point using the left mouse button and 
drag to a new place. For precise positioning of the control point, use the 
mouse and keyboard jointly. While holding the left mouse button, use the 
arrow keys to move the control point one by one cursor step. Use the Shift 
key for cursor jump to the closest node of design grid, the - and + keys for 
changing the cursor step, / and * keys for scaling of the view. 

During the operation, the control points (vertices) can be added and/or 
removed to form the desired configuration of the element. 

To insert a new control point, right-click on one of the existing control points, 
and then click Add Vertex item in the popup menu. New control point is 
inserted in the middle of the segment connecting the selected point and the 
adjacent, in a counterclockwise direction. 

To remove an existing control point, right-click on it and choose Delete 
Vertex item in the popup menu. 
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To complete the transformation, double-click the left mouse button or press 
Enter. To cancel the procedure, press Esc. 

Numeric Transformation 

Transformation by changing numeric values of the parameters via dialog is 
performed for an arbitrary number of selected elements. By using this 
procedure, the elements can be reproduced many times at a given step in the 
horizontal and vertical directions, shifted, scaled and rotated by an arbitrary 
angle with respect to a predetermined point. Furthermore, during coping of 
elements one can also set the dose increment for the new elements in one of 
two ways: increasing by a predetermined value or sequential multiplication of 
a dose by a predetermined coefficient. 

To perform the transformation, select elements and then, choosing the Edit-
>Transform->Numeric... menu item or by pressing the Ctrl+Shift+N key 
combination, open the Numeric Transformation dialog (see Fig. 12). 

 
Fig. 12. Transformation of elements by using the Numeric Transformation dialog 

Click Clear button to set transformation parameters to default values. 

In order to displace the elements set shift values in the Shift X and Shift Y 
field, in microns. 

Define a pivot point relative to the origin of the design in the Base Point 
fields. The elements rotate around and scale from this point. 

Specify, if necessary, rotation angles in the Rotate fields, scaling coefficients 
in the Magnification fields, number of repeats and steps in fields of Repeat 
group and/or coefficient of scaling or increment for a dose in the fields of 
Repeat Dose Operation group. 

Check the Save Old control to preserve the original elements in addition to 
newly created elements at transformation. 

Check the Select Old control to leave the original elements selected after 
transformation. 

Check the Select New control to select transformed elements after procedure. 

Press OK to close the dialog box and perform the transformation. 
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Move&Rotate 

In order to move and/or rotate elements on any distance or angle, select the 
elements and choose the Edit->Transform->Move&Rotate menu command 
or use the Ctrl+Shift+M shortcut keys. 

Immediately after this transformation mode is activated: the mouse pointer is 
captured in the window, special cursor is appeared, and information panel is 
opened in the upper right corner of the window. 

When mouse pointer is over the selection within an imaginary rectangular area 
that outlines the outstanding vertexes, the cursor takes the form of a pointer 

with a crosshair . If mouse pointer is outside an imaginary rectangular 

area, the cursor takes the form of a pointer with an open circle , 
symbolizing the rotation operation. 

To move the elements to desired place of the structure, place cursor inside the 
imaginary rectangular area, grab them by pressing the left mouse button and 
holding it, drag to the right place. When moving, the elements images are 
drawn in dashed lines. The geometric center of the images (center of the 
circumscribed rectangle) is indicated by dashed crosshair. 

If you want to rotate the elements, place cursor out of an imaginary 
rectangular area, grab them by pressing the left mouse button and holding it, 
move cursor along big arc, which outlines the elements, as long as the images 
will not receive the desired position. 

Before dragging, move mouse pointer close to geometric center of the image 
at a distance less than half the cursor step. Now, when you press the left 
mouse button, the pointer will jump to the position of the geometric center. 
And thus, at the further dragging, it is easier to control position of the image. 
For more convenience and accuracy, use the arrow keys to move the image 
with cursor steps. If necessary, use the - and + keys to change the cursor 
step, as well as / and * keys (or mouse wheel) for scaling. 

To place the elements in the right place press Enter key or double-click the left 
mouse button. 

To cancel transformation, press the Esc key or double-click the right mouse 
button. 

Rotate 180º 

In order to rotate element by 180 degrees with respect to its geometrical 
center, select the element and choose the Edit->Transform->Rotate 180º 
menu command or use the Ctrl+Shift+8 shortcut keys. If a group of elements 
are rotated, then rotation will be performed with respect to the total geometric 
center. 

Rotate 90º CW 

The command rotates element or group of elements by 90 degrees clockwise 
relative to the geometric center of the selected objects. To perform this 
operation, choose the Edit->Transform->Rotate 90º CW menu command 
or use the Ctrl+Shift+9 shortcut keys. 

Rotate 90º CCW 

The command rotates element or group of elements by 90 degrees 
counterclockwise relative to the geometric center of the selected objects. To 
perform this operation, choose the Edit->Transform->Rotate 90º CCW 
menu command or use the Ctrl+Shift+7 shortcut keys. 

Flip Horizontal 
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The command flips a selected element or group of elements relative to an 
imaginary vertical axis passing through the geometric center of the selected 
objects. To perform this operation, choose the Edit->Transform-> Flip 
Horizontal menu command or use the Ctrl+Shift+H shortcut keys. 

Flip Vertical 

The command flips a selected element or group of elements relative to an 
imaginary horizontal axis passing through the geometric center of the selected 
objects. To perform this operation, choose the Edit->Transform-> Flip 
Vertical menu command or use the Ctrl+Shift+V keyboard shortcut keys. 

 

3. Transformation of attributes and geometry of elements 

Transformation by formula 

Dimensions, spatial position and attributes of selected elements can be 
simultaneously changed by entering the appropriate mathematical expressions 
in Transform By Formula dialog. 

In order to perform this transformation, select elements and open the dialog 
with the Edit->Transform->By Formula... menu command or by pressing 
the Ctrl+Shift+F shortcut keys. Further, in the dialog window, enter one or 
more mathematical equations characterizing conversion of the attributes 
and/or geometric parameters of all selected elements in accordance with 
certain rules. These rules are as follows: 

• All expressions mostly are assignment operations to variable on the left 
of equal sign the result of calculations performed on the right side of the 
expression. For example, the expression might look like: 

coef = 100; d = coef * log (d); 

The first statement declares a variable coef, which is assigned the 
number 100. In the second expression is evaluated the product obtained 
by multiplying variable coef and logarithm of variable d. The result is 
then assigned to d. As will be discussed below, the variable d is reserved 
to denote dose of an element. Thus, as a result of transformation with 
use of the above expressions, the dose of each of the elements will be 
redefined in accordance with the expression: d = 100 * log (d); 

• At the end of an expression should be semicolon; 

• Expressions can be written in a line leaving spaces between them; 

• To improve readability, you can insert spaces in expression. 

• Mathematical expressions are case insensitive. Therefore, the 
expressions shown in the example below are equivalent expressions in 
the first example: 

Coef = 100 ; d = coeF * Log (D); 

• Arguments of mathematical functions should be placed in parentheses, 
as in the example above. 

 
• List of available mathematical functions extensive and listed in Help. 

• The following mathematical operators are used in the expressions: 

+  - addition or plus sign; 

-  - subtraction or minus sign; 

*  - multiplication; 

/  - division; 

^ or ** - exponentiation. 

• Expressions can include logic operations and include the following logical 
operators: 
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>  - greater than 

>=  - greater than or equal 

<  - less than 

<=  - less than or equal 

<>  - not equal 

&&  - and 

||  - or 

TRUE  - result of logic operation equals to 1 

FALSE  - result of logic operation equals to 0 

• The following symbols are not allowed in expressions: ~ ` % # @ & $ { 
} [ ] " ' ? | \ ! 

• The appearance of any of these symbols in expressions will interrupt the 
transformation with the appropriate message. 

• Circular constant Pi = 3.14159… is the predefined variable. 

• The following variables are reserved in expressions: 

D for dose, A for 3D attribute, L - for layer; 

Zx - scaling factor along X axis. Scaling is performed relatively to the 
geometric center. Center is calculated by the formula: (Minx + 
Maxx) / 2. 

Zy - scaling factor along the Y axis. Center is calculated by the 
formula : (Miny + Maxy) / 2. 

Rx - angle of pivoting movement around the geometric center with 
respect to the X axis, in degrees. Center is calculated by the 
formula: (Minx + Maxx) / 2. 

Ry - angle of pivoting movement around the geometric center with 
respect to the Y axis, in degrees. Center is calculated by the 
formula: (Miny + Maxy) / 2. 

Sx – shift of an element along the X axis, in um, Sy - shift of an 
element along the Y axis. 

Minx and Maxx – most outstanding coordinates of element along the 
X axis (in μm), which can be used for transformation as initial 
data. 

Miny and Maxy - most outstanding coordinates of element along the 
Y axis (in μm), which can be used for transformation as initial 
data. 

Entered expressions, for easy reuse, can be saved as a text file. To do this, 
press Save FRM... button and in the Save Formula File dialog, specify a file 
name and save it. Text file with formulas has FRM extension. To load 
previously created formulas, press Load FRM... and select the file. 

Press OK to close the dialog and perform the transformation. 

Ungroup 

If you need to transform structure insertion (Structure reference, Dose map, 
Reference map) or Time&Date or Comments to the set of their constituent 
elements, selects the insertion / Time&Date / Comments and choose the Edit-
>Ungroup menu command (or press U hotkey). It may take some time in case 
of a large number of elements. In this case, a progress bar will appear in the 
status bar that displays the percentage of completion. It should be noted, this 
procedure would increase the size of the data file. 
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Designing with an image in background 

Suppose, that on the surface of your substrate is formed some structure or there 
is some relief, and you want to design new elements that would fit into the 
existing pattern. In this case, using an image as a background can help you 
design. To begin the design, you need to take an image of the interested surface 
and save it in TIFF format (8 bit/pixel). If you acquire a picture with the 
NanoMaker, then you can essentially simplify the task of calibrating the resulting 
image. 

Acquire image in a calibrated field (Scan Field) that will allow you to store in the 
tags of TIFF file the real sizes. It is convenient to use the Microscope dialog to 
capture the image. This will allow you to orient interested area and set the center 
position, which will be the anchor point of the image to the origin in the editor 
window. 

Also, you can use a photo taken with any other device, but before using it in the 
editor as a background: 

• convert it to a TIFF format (8bit/pixel); 

• use the Image Processing dialog (Video->Microscope->Processing...) 
to set the real scale. For that, using your knowledge about actual size of the 
image, fulfill the Rescale operation, and define center of the image by 
pressing the Set Origin button; 

• save the transformed image by pressing the Save Image button. 

For the beginning open a new GDB file (File->New Database) and then load the 
desired image (View->Redraw->Background). Now you can start designing, 
using the background image as the basis for the newly created elements (see Fig. 
13). 

  
Fig 13. Structure design using background image 

Brightness of the background image can be changed for the convenience of the 
design. To do this, open the Image tab of the View Options dialog (Options-
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>View->Image tab) and adjust in the Tone group the cropping of the brightest 
pixels in Auto or Manual modes. After closing the View Options dialog, in the 
editor window press the Alt+C shortcut keys to redraw the view. 

Saving 

Upon completion of the work, the results of patterns design have to be saved in 
GDB file. If a new structure was designed or you made minimal changes to the 
existing structure, then select the File->Save menu command to save the data 
in an existing file. If the changes are substantial, with many deleted and newly 
created elements, then it is recommended to use the File->Save As menu 
command and save the design in a new GDB file, which in some cases will 
significantly minimize the file size. 



Operational manual Designing Lithographic Structures 

www.nanomaker.com 29

 

DESIGNING LITHOGRAPHIC STRUCTURES 

Designing of a dose wedge structure 
This section describes an example of designing a dose wedge structure. This 
structure can be used to determine contrast of a resist (the development rate as 
a function of the exposure dose) and its sensitivity. Description of the method for 
determining a contrast is given in the article published at site [1]. 

To design this structure a few editing techniques are used including 
transformation of elements by formulas and numerical form transformation 
(corresponding menu commands are - Edit->Transform->By Formula and 
Edit->Transform->Numeric). 

For the beginning, create a new GDB file by using File-> New Database 
command. While determining parameters in the New Data Base File dialogue do 
not define database grid and leave the default resolution of 1 nm (see Fig. 1). 
Press OK button to close the dialogue and open an editor window for MAIN 
structure. 

 
Fig. 1  Set parameters for a new database file in New Database File dialogue 

Then, open the Attributes dialogue by using Insert->Attributes... command. 
Use this dialog to define attributes for the elements that will be created, 
particularly set dose (Dose [%]) equal to 100% (see Fig. 2). Close the dialog. 

 
Fig. 2  Define attributes for new elements in Attributes dialogue 

In just created window for the Main structure introduce rectangular element 
with coordinates of left-bottom vertex – (0, 0) μm and right-top vertex (2, 50) 
μm, respectively (see Fig. 3). 
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Fig. 3  Parameters for transformation using Numeric Transformation dialogue 

By numeric transformation, propagate the rectangular element 101 times along 
the X axis with incrementing dose for each subsequent element by 1%. To do 
this: 

 Select element with Alt+A shortcut keys; 

 Open the Numeric Transformation dialogue by choosing the menu 
command Edit->Transform->Numeric... (or Ctrl+Shif+N shortcut 
keys); 

 In the dialogue specify number of repetitions along X axis (Repeat X) 
equal to 101 with steps (Step X) equal to 2 μm. Set dose increment (Dose 
Increment) to 1 % (see Fig. 3); 

 Press OK button, to close the dialog and perform the transformation. 

The transformation will create an array of 101 contiguous rectangular elements in 
which the dose d0 (Dose attribute) increases linearly from left to right from 100% 
at the far left to 200% at the far right. 

To implement the method for determining contrast in accordance with [1] one 
need to define such exposure dose distribution in a wedge, that after 
development, the resist thickness decreases linearly from its left edge to right 
one. Such nonlinear dose distribution is given by a transformation formula. Since 
the development rate of the positive resist v is proportional to dγ, where γ is the 
resist contrast (according to formula 1 in [1], then transformation of the 
element's dose according to the formula 

1
0100*( 1)

100
dd γ= −  

will create a dose distribution in wedge from 0 to 100%. Here d0 - initial dose of 
the element. 

And, if a real resist contrast will correspond to the used value γ, then perfectly 
linear wedge will be formed after development. 
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To transform dose of rectangular elements by formula: 

 Selects all elements in structure by Alt+A shortcut keys; 

 Open Transform by Formula dialogue, by selecting the Edit-
>Transform->By Formula... menu command (or Ctrl+Shif+F shortcut 
keys); 

 
Fig. 4. The transformation formula in Transform by Formula dialogue. Selected rectangular 

elements are seen in the background. 

 Enter the following formula in dialogue window: gamma = 4; d = 100 * 
(d/100-1) ^ (1/gamma);, where the supposed value for contrast gamma 
equals to 4 (see Fig. 4); 

 Press OK to close the dialogue and perform the transformation. 

 

The resulting dose wedge structure design is shown on Fig. 5 (in dose displaying 
mode). 

Do not forget to save the newly created structure. 

In the above-mentioned article [1], to determine contrast, the seven dose 
wedges were designed for seven supposed contrast values. After exposure and 
development it was found that a linear profile of the wedge is achieved for 
contrast value equal to 3 (on Fig. 6 the values to the right of the wedges). The 
constancy of the distance between the interference fringes shows the linearity of 
the wedge profile. 
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Fig. 5. Resulting dose wedge structure design in dose display mode. 

 
Fig. 6 The photo of produced structure to determine the resist contrast. An equal distance between 

the interference fringes shows the linearity of the resulting profile. Closest to this is the middle wedge 
corresponding to contrast value equal to 3. 

 

[1] www.nanomaker.com/nav.php?go=paper8. 
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